WHMCS Bridge and WHMCS Bridge Pro Installation Instructions

Important Notes:

1.

WHMCS Bridge may require some CSS adjustments if you are using a theme that was
not built to be compatible with WHMCS Bridge.

For more information please visit our KB: https://i-plugins.com/whmcs-
bridge/knowledgebase/1039/The-integration-is-not-perfect-how-do-I-tweak-it.html/

If you have purchased a WHMCS Bridge enabled theme and your Bridge is not
displaying correctly, you need to contact the theme creator who you purchased the
theme from for support.

We are not affiliated with theme creators and if they have charged you for a theme that is meant
to render perfectly with the bridge this is something they will need to resolve for you.

WHMCS Bridge is a separate product to WHMCS. You will need an existing WHMCS
installation and license from WHMCS for this.

If you do not have a license, please visit this URL to get yourself one:
https://www.whmcs.com/members/aff.php?aff=23386

You will need to complete your WHMCS Setup before proceeding with WHMCS Bridge. Please
contact WHMCS support direct for queries related to WHMCS.

All third-party cache plugins *must* be disabled for the WHMCS Bridge page.

All good caching plugins for WordPress have an option to disable caching for a particular
URL/matching part of a URL.

If your whmcs bridge page is www.yoursite.tld/whmcs-bridge/ then you can configure your
cache plugin to exclude /whmcs-bridge* (meaning all pages under whmcs-bridge).

Why? These plugins treat WordPress pages as static, but WHMCS Bridge content changes and if a
cache plugin is enabled you run the risk of it caching a clients logged in session, which would
then show their details to every subsequent visitor.

CloudFlare should be set to bypass & disable all CloudFlare apps for the URL. But
ideally disabled completely.

Unfortunately, CloudFlare causes problems with AJAX requests which we have yet to resolve, we
have reached out to CF but have not found a solution. Some users are lucky enough to keep CF
on their site and just disable & bypass for their /whmcs-bridge/ URL but generally users have to
disable CloudFlare completely.

Pro users: Both WHMCS Bridge and WHMCS Bridge Pro (aka SSO) plugins must be
activated in WordPress.

Pro users: Our main release channel via WordPress Updates is for PHP 7.2 with
lonCube encoder. If you are using a different version of PHP you must download
updates from our website.

Details on how to download below.

Installation Requirements:

1.

Your WordPress must have Pretty Permalinks enabled, ideally using “Post name”.
The plugin does not work with ?page_id=XXX URLs or index.php/page-name URLs.
For setup information of WordPress Pretty Permalinks please visit:
https://wordpress.org/support/article/using-permalinks/#mod _rewrite-pretty-
permalinks

Your WHMCS and WordPress can be on the same hosting account, or across
different hosting accounts, but you should have a hosting account with sufficient
resources to support the plugin. PHP’s memory_limit should be at least 256MB and
CloudLinux users should ideally split WHMCS and WordPress over two different




accounts. For more information please visit: https://i-plugins.com/whmcs-
bridge/knowledgebase/1073/Help-My-site-is-running-slow-using-your-plugin.html
3. While PHP 5.6 is currently supported it is recommended you use PHP 7.1 or PHP 7.2.




1. Download & install WHMCS Bridge

From your WordPress Admin, go to Plugins > Add New and search for “WHMCS Bridge”

WHMCS Bridge Install Now
WHMCS Bridge is a plugin that integrates the More Details
powerful WHMCS support and billing software
with...
By globalprogramming
(55) Last Updated: 3 months ago
10,000+ Active Installations v Compatible with your version of WordPress

Click on the “Install Now” button, and then “Activate”.

You can also go to https://wordpress.org/plugins/whmcs-bridge/ and download the latest
ZIP file from there. You will then need to upload it via your WordPress Admin uder Plugins >
Add New > “Upload Plugin” button.

2. Capture initial Settings

Once the plugin is activated, go to Settings > WHMCS Bridge
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On this settings page you must fill in your WHMCS URL into the first box on the page under
Integration Settings.

& WHMCS URL |

** Important: This URL must be exactly as it is in your WHMCS Admin under Setup > General
Settings > WHMCS System URL, ideally you should copy and paste the URL (even differences
such as one having “www” and the other not, will cause problems.

WHMCS System URL https://i-plugins.com/whmcs/

The URL to your WHMCS installation (SSL Recommended) eg. https://www.example.com/members/
Once you have done this, click on “Save Settings”.
Now, go to your WHMCS Admin under Setup > General Settings and make sure your

Friendly URLs are set to “Basic URLs”

Friendly URLs = Basic URLs ~

Note: Friendly index.php is not support and Full Friendly Rewrite is only supported by
WHMICS Bridge Pro.

Once the page has reloaded you can visit the “Help” tab to see the URL of your WHMCS
Bridge page.

£+ Settings ¥ Log < Sync i Help
The Bridge Page

A WHMCS front end page has been created on your WordPress site.
This page is the main interaction page between WordPress and WHMCS.

The full urlis: http://demopage.cf/whmcs-bridge/

You can edit the page link by editing the page and changing the permalink.
Do not delete this page!

If you'd like to change the “whmcs-bridge” to something else, you can do it as you would
with any other WordPress page. In WordPress Admin > Pages find your WHMCS Bridge
page, choose “Quick edit” and change the title and slug to your desired new URL. Once
saved you can go back to your “Help” tab in WHMCS Bridge settings and you will see the
URL has updated.



QUICK EDIT

Title WHMCS Bridge Client Area Parent

Slug whmgs-bridge-clients S

Date 09—Sep¢ 21 , 2019 @ 10 : 00 Allc

Password —OR- Private Status
Cancel

£+ Settings ¥¥ Log < Sync i Help

The Bridge Page

A WHMCS front end page has been created on your WordPress site.
This page is the main interaction page between WordPress and WHMCS.

The full urlis: http://demopage.cf/whmcs-bridge-clients/

You can edit the page link by editing the page and changing the permalink.
Do not delete this page!

3. Installation Completed of WHMCS Bridge Free

This is the end of the installation instructions for the free version of WHMCS Bridge. You can
visit your WHMCS Bridge page to see if it is rendering correctly and if not please make use of
the various options on the WHMCS Bridge settings page.

Scoping CSS can help avoid conflicts between a WordPress theme’s CSS and WHMCS's CSS.
The Custom CSS box is also there for you to capture any styles you want applied to the
WHMCS Bridge page.

If you are having JavaScript conflicts (eg: your domain search returns a blank page with
text), you can also try switching your jQuery library option in WHMCS Bridge Settings.



Styling Settings
(BETA) Select if you want to prefix WHMCS CSS rules with #bridge, this will help avoid styling conflicts

@ Scope WHMCS CSS
Select the jQuery library you want to load. If you have a theme using jQuery, you may be able to solve conflicts by choosing a different library or

no library. Note that WHMCS Bridge uses the jQuery $ function, hence it needs to be defined if you manage the loading of jQuery in your
WordPress theme.

S jQuery library WHMCS %
Enter your custom CSS styles here

</> Custom CSS

#bridge .container {
width: 100% limportant;
}

4. Installation of WHMCS Bridge Pro (aka SSO) in WordPress

Purchase WHMCS Bridge Pro (aka SSO) (trial or Premium) via https://i-plugins.com/whmcs-
bridge/cart/?a=add&pid=20 to get your license code and access the downloads for WHMCS
Bridge Pro.

Log in to your account @ https://i-plugins.com/whmcs-bridge/clientarea/ and click on
Support > Downloads

Support ~ Open Ticket

Tickets
l.S Announcements
Knowledgebase
ntAres Downloads

Network Status

Browse to Software > WHMCS Bridge (https://i-plugins.com/whmcs-
bridge/download/category/3/WHMCS-Bridge.html/)




Make sure to download WordPress Plugin — WHMCS Bridge for the PHP version that your
WordPress installation is running on.

Make sure to download WHMCS Addon — Bridge WP for WHMCS Bridge for the PHP version
that your WHMCS installation is running on (Installation for this will be covered later).

Navigate to your WordPress Admin > Plugins > Add New > Upload plugin and upload the
whmcs-bridge-sso.zip file (filename may vary if you downloaded for a different version of

PHP).

Choose file Whmcs-bridge-sso.zip

Install Now

Activate the plugin

Installing Plugin from uploaded file: whmcs-bridge-sso.zip

Unpacking the package...
Installing the plugin...

Plugin installed successfully.

Activate Plugin Return to Plugin Installer

5. Configuration of WHMCS Bridge Pro (aka SSO) in WordPress

Navigate to WordPress Admin > Settings > WHMCS Bridge and fill in your WHMCS Bridge
License Key

& License Key | 1234567890-abcdefg

It is recommended you enable Cache for the longest period of time

¥ Cache images, CSS & JS 30days ¢



It is also recommended you enable Pretty Permalinks (SEO URL’s)
Q Pretty Permalinks (SEO URL's)

Please also remember to change your WHMCS Admin Setup > General Settings > Friendly
URLs to Full Friendly Rewrite

Friendly URLs  Full Friendly Rewrite ~

Click on Save Settings to update.

6. Setting up Synchronisation
In your WHMCS Admin navigate to Setup > Staff Management > Manage API Credentials:

Under API Roles create a new role for WHMCS Bridge accessing the APl with the rights
under Authentication, Client, Domain, Module, Products, Servers, Service, System.

Under API Credentials Generate New AP| Credentials

Generate New API Credential

Below is the unique access Identifier and the Secret. You must copy the Secret now as it
cannot be retrieved later.

Identifier

LTuzVdasdasd#casc8jvh)4P2tf3KT

Secret

pv59332131CnasiAQWUYKXI12eqWbj

Copy the Identifier into your WHMCS Bridge Settings under WHMCS API Identifier and
WHMCS API Secret



& WHMCS API Identifier

The password of the WHMCS API user.

=« WHMCS API Secret

Save your settings.

In your WHMCS Admin under Setup > General Settings > Security, scroll down to “API Access
Restriction” and click on “Add IP” to add your WordPress Server IP.

To be sure what the WHMCS API is detecting as your IP is, you should go to your WHMCS
Settings under the Help tab and click on “Check for problems with my setup” and check for
an error relating to the API.

7. Setting up Single Sign On with WHMCS

WHMCS has introduced a new requirements for allowing external systems to post to the
WHMCS login page:

https://docs.whmcs.com/Linking to WHMCS#Integrating The Login Form into _your We
bsite

You will need to add the following line to your WHMCS configuration.php file:

$allow_external_login_forms = true;

8. Install WHMCS Bridge Addon for WHMCS

Unzip the bridgewp.zip file that you downloaded from our website (WHMCS Addon — Bridge
WP for WHMCS Bridge) and upload it to your WHMCS installation via FTP into
modules/addons.

A public_html ) i-plugins.com ) whmcs » modules H h ddo "ﬂ

Name 4

» |9 br_order_assistant

B bridgewp

» |9 bulkpricingupdater

Then move the bridgeipfix.php file from within the bridgewp folder into your root WHMCS
folder.



B2 )/ ) public_.html ) i-plugins.com M

Name 4
» I auvacnments

/' banned.php
. bridgeipfix.php
cart.nhn

Once this has been done, edit the configuration.php file in your root WHMCS folder and add
the line:

require once _ DIR .”/bridgeipfix.php”;

14 | /1 clientarea.php
35 /| configuration.php
15 | ranfiruratinn nhn naw
5 @0 @
<?php

25 2 | $license = 'xxxx';
% s | $db_host = 'localhost';
Y0t $db_username = 'xxx';
3 $db_password = 'xxxx';
13 5 | $db_name = 'xxx';
2 $mysql_charset = 'utf8';
s $customadminpath = 'xxx';
35 s | $api_access_key = 'xxx';
19 o | $display_errors = true;

11 | require_once dirname(__FILE__).'/bridgeipfix.php';
27 2
32

This will correct the issue of WHMCS picking up your WordPress hosting IP address as your
clients IP addresses when using the bridge.

9. Configure WHMCS Bridge Addon for WHMCS

Log in to your WHMCS Admin and navigate to Setup > Addon Modules

General Settings
Apps & Integrations
Sign-In Integrations
Automation Settings
MarketConnect
Notifications

Storage Settings

Staff Management

Payments
Products/Services
Support
Application Links
OpenlID Connect
Email Templates
Addon Modules
Client Groups
Custom Client Fields
Fraud Protection
Other

Click on Activate next to the “WHMCS Bridge Helper” plugin, once done click on “Configure”



» WHMCS Bridge Helper

Adds the possibility to redirect customers to your WordPress ) )
5.1 -Plugins Activat Deactivat Configure

WHMCS page. (This addon was previously known as Bridge Frugl ctivate eactivate '8u

Redirect but now comes with more functionality).

) https://i-plugins.com/whmcs-bridge/ The full page URL to your WordPress WHMCS
WordPress Bridge page
URL bridge page. You can see this in your WordPress WHMCS Bridge settings page. You can leave this blank if you

don't want the redirect to be active.

Pretty permalinks Check this if you have activated pretty permalinks in WHMCS bridge settings on WordPress.

Disable _ L ) - .
viewinvoice/viewauote WHMCS uses a non templated page for viewinvoice and viewquote. Check this if you want to avoid people
re?‘lirect visiting viewinvoice.php or viewquote.php to be redirected to the correpsonding page on your WordPress site.

Debug log Check this if you encounter issues. The system will write redirect messages into the Activity Log.

Choose the admin role groups to permit access to this module:

Access Control . - L ) . —
Full Administrator Full Administrator - No Notifications Sales Operator

Support Operator

Save Changes

In WordPress Bridge page URL you will fill in the bridge page on your WordPress website
(found in the “Help” tab). This will redirect users who visit your direct WHMCS URL to the
correct URL on your bridge automatically (for things like links in automated emails from
WHMCS - do not change any of your email templates or your WHMCS System URL — this will
cause problems with your WHMCS installation).

Please note:
- If you are logged in as WHMCS Administrator, the redirects will not fire. If you want

to test the redirects to your WHMCS Bridge, log off from WHMCS Admin.
- If you do not want to redirect users to your WHMCS Bridge page, leave the
WordPress Bridge page URL field blank and Save Changes.

10. Important .htaccess rules for WHMCS Bridge (Password
Reset, PayPal)

Please see this article: https://i-plugins.com/whmcs-
bridge/knowledgebase/1098/Important-.htaccess-redirect-for-WHMCS-Bridge.html/

11. Installation of WHMCS Bridge and Bridge Pro completed.
The basic install of WHMCS Bridge with WHMCS Bridge Pro and the WHMCS Addon is now

complete. Please read through all the options on the settings page to assist with tweaking
your installation or debugging any issues you may have.
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